Problems with the LED Lantern Posts?

User avatar
dice4hire
Minotaur Lord
Minotaur Lord
Posts: 3323
Joined: Thu May 02, 2013 7:13 pm
Location: Nagoya Japan

Re: Problems with the LED Lantern Posts?

Post by dice4hire » Sun Jul 23, 2017 7:37 am

This thread has convinced me to pass on the posts.
A pretty decent Docent of Valoria

Bossman
Orc
Orc
Posts: 157
Joined: Tue Nov 27, 2012 6:15 am

Re: Problems with the LED Lantern Posts?

Post by Bossman » Sun Jul 23, 2017 12:44 am

Update - mine are all painted but by pulling the column away from the base the joint opened up between the base and the column to a bit over halfway along the contact. The joint in the column cunningly follows the stonework which can be gently pulled apart. This opened up the problem area where the LED socket is loose. This was then easilly retrieved and glued back in place.

The factory glue job just looks like a hot glue blob with no rear support so it easy to see why they can push in.
With some super glue the whole column is restored back to almost original condition.

User avatar
jchunick
Minotaur Lord
Minotaur Lord
Posts: 3068
Joined: Mon Nov 11, 2013 6:49 pm
Location: Thunder Bay
Contact:

Re: Problems with the LED Lantern Posts?

Post by jchunick » Thu Jul 20, 2017 5:18 pm

I haven't had it happen on any of mine yet, but if it does then the repair I'll be trying is to pull them back through with some small pry tools I have that are normally used for electronics (or one of the many other small tools I have for sculpting and the like), and then being very careful to apply crazy glue on the end of a toothpick and get into the crevices between the socket and pillar. That should do it. I would think that a crazy glue that's more watery than gel-like is probably best to seep into the cracks. The trick is not getting it into the socket holes themselves... you could cut a very small piece of masking tape to tape over the sockets.
If you aren't gaming then you aren't living.

Bossman
Orc
Orc
Posts: 157
Joined: Tue Nov 27, 2012 6:15 am

Re: Problems with the LED Lantern Posts?

Post by Bossman » Thu Jul 20, 2017 4:51 pm

Same problem on just a couple. Has anyone worked out a repair?

User avatar
Runeweaver
Ogre
Ogre
Posts: 971
Joined: Sat Feb 18, 2012 3:33 am
Location: Oregon, US

Re: Problems with the LED Lantern Posts?

Post by Runeweaver » Thu Jul 20, 2017 4:45 pm

Yep, had it happen with one of mine.

User avatar
whyteshark
Goblin
Goblin
Posts: 91
Joined: Sat Apr 04, 2015 9:57 pm
Location: Edmonton

Re: Problems with the LED Lantern Posts?

Post by whyteshark » Thu Jul 20, 2017 12:47 am

I have one with a connector pushed in too. I have a couple of the base LED posts that have the same problem. I have contacted DF about it.
James Gordon, Professor of Valoria

User avatar
jchunick
Minotaur Lord
Minotaur Lord
Posts: 3068
Joined: Mon Nov 11, 2013 6:49 pm
Location: Thunder Bay
Contact:

Re: Problems with the LED Lantern Posts?

Post by jchunick » Tue Jul 11, 2017 11:41 pm

KenCOWrite wrote:
Tue Jul 11, 2017 10:57 pm
I got one set - all the connectors pushed in, so no connection possible to LED. It appears that if you try to push in the lanterns, they light up, but if you try to push them in so they are held in place, the pins push the connectors into the post.
Anyone had any success in attaching an LED and having it stay in place?
I am nervous to try again as I don't want to request another replacement
That shouldn't happen, but I know exactly why it does since I do the prototypes and have had it happen on mine when I haven't secured the sockets properly. This sounds like a manufacturing flaw and should be reported to Suzy at Dwarven Forge.
If you aren't gaming then you aren't living.

KenCOWrite
Kobold
Kobold
Posts: 18
Joined: Tue Mar 22, 2016 3:50 pm
Location: Louisville, CO
Contact:

Re: Problems with the LED Lantern Posts?

Post by KenCOWrite » Tue Jul 11, 2017 10:57 pm

I got one set - all the connectors pushed in, so no connection possible to LED. It appears that if you try to push in the lanterns, they light up, but if you try to push them in so they are held in place, the pins push the connectors into the post.
Anyone had any success in attaching an LED and having it stay in place?
I am nervous to try again as I don't want to request another replacement

Saxon1974
Orc
Orc
Posts: 373
Joined: Mon Jul 01, 2013 6:25 pm

Re: Problems with the LED Lantern Posts?

Post by Saxon1974 » Sat Jul 01, 2017 5:51 pm

Got 1 set without this issue however I am missing the bottom on one of them:) these are pretty wobbly for pillars it seems.

User avatar
DrGerm
Kobold
Kobold
Posts: 15
Joined: Sat Apr 27, 2013 4:49 pm
Location: Indianapolis
Contact:

Re: Problems with the LED Lantern Posts?

Post by DrGerm » Sat Jul 01, 2017 4:59 pm

lostpict wrote:
Fri Jun 30, 2017 10:50 pm
Yes, it is unfortunately a Known Problem. Contact Suzy at DF for replacements.
Thank you!

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests